漏洞通知:Apache Struts2远程代码执行漏洞(CNVD-2016-04093)

Apache Struts2远程代码执行漏洞(CNVD-2016-04093)

CNVD-ID CNVD-2016-04093 录入时间 2016-06-16
危害级别 中危   评分:4.3 报送时间 2016-06-16
产生原因 设计错误 归档时间 2016-06-17
引发威胁 未授权的信息修改 公开时间 2016-06-20
攻击位置 远程 发现时间 2016-06-16
影响对象类型 应用程序漏洞 是否热点漏洞
涉及厂商 Apache
影响产品 Apache struts >=2.3.20,<=2.3.28.1
CVE ID CVE-2016-4436
漏洞描述 Apache Struts是美国阿帕奇(Apache)软件基金会负责维护的一个开源项目,是一套用于创建企业级Java Web应用的开源MVC框架,主要提供两个版本框架产品,Struts 1和Struts 2。Apache Struts 2是Apache Struts的下一代产品,是在Struts 1和WebWork的技术基础上进行了合并的全新Struts 2框架,其体系结构与Struts 1差别较大。 Apache Struts 2.3.20版本至2.3.28.1中存在远程代码执行漏洞。攻击者可借助特制的输入利用该漏洞生成恶意的负载,实施攻击。
参考链接 https://cwiki.apache.org/confluence/display/WW/S2-035
解决方案 目前厂商已经发布了升级补丁以修复此安全问题,详情请关注厂商主页: http://struts.apache.org/
厂商补丁 Apache Struts2远程代码执行漏洞(CNVD-2016-04093)的补丁
补丁编号 CNPD-2016-77687
补丁描述 Apache Struts是美国阿帕奇(Apache)软件基金会负责维护的一个开源项目,是一套用于创建企业级Java Web应用的开源MVC框架,主要提供两个版本框架产品,Struts 1和Struts 2。Apache Struts 2是Apache Struts的下一代产品,是在Struts 1和WebWork的技术基础上进行了合并的全新Struts 2框架,其体系结构与Struts 1差别较大。 Apache Struts 2.3.20版本至2.3.28.1中存在远程代码执行漏洞。攻击者可借助特制的输入利用该漏洞生成恶意的负载,实施攻击。目前,供应商发布了安全公告及相关补丁信息,修复了此漏洞。
补丁链接 http://struts.apache.org/
验证信息 未验证

 

发表评论

电子邮件地址不会被公开。